CAD Software Direct
            Knowledgebase CAD Software Direct General / Software Queries SketchUp Pro

            SketchUp - Optimising Modeling Techniques

            SketchUp renders what you see in the drawing area every time you move around, create or edit your model. The more edges and materials etc you have, the more work SketchUp has to do. Keeping your model light and optimised is a great way of keeping SketchUp running fast as you're giving it less work to do.

            Take a look at these tips to improve SketchUp's performance by keeping your model light:

            Stick to simple styles

            Turn off textures, shadows and any other special effects when you don't need to see them.

            Use Components

            If you're using the same object (e.g. a door or plant), make it a component, and then use copies of it. Multiple instances of a component are lighter than copies of an entity or group.


            Hide geometry you don't need

            The more visible geometry you have, the slower SketchUp will run. You can improve performance by controlling geometry visibility with layers. For example, if you need to move around an interior faster, you could group all the furniture together and toggle their visibility all at once.

            Use .jpg instead of .tiff

            Whenever you import images into your model, different file types can make a big difference on overall scene size. For example, a JPEG may provide sufficient quality compared to a TIFF, which may be harder to compress. Large file sizes take more computing resources to display.

            Understand and Monitor the Polygons in Your Scene

            SketchUp Polygon CountSketchUp uses polygons to construct forms. The number of polygons in a model is one of the biggest factors affecting overall performance. The more there are, the greater the calculations the processor and graphics card need to make to modify and display the scene. Polygons are listed as 'faces' in the Model Info > Statistics window. Beware of importing third party models (such as trees) which may contain high numbers of polygons and suddenly and substantially increase the size of your scene.

            Disable shadows and fog

            Fog and shadows are quite intensive for 3D applications. You can select View > Shadows to deselect the Shadows menu item. To turn off fog, select View > Fog to deselect the Fog menu item.

            Purge unused data

            SketchUp stores data that you've previously used in your model even if you don't have them there any more - just in case you need them back later. To purge all your unused items at once, select Window > Model Info, select Statistics in the sidebar on the left, and click the Purge Unused button.

            Updated: 09 Sep 2019 01:32 PM
            Helpful?  
            Help us to make this article better
            0 0